Feature #2

Runtime keystrokes

Added by Richard Methot over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:01/09/2012
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:ADMB 11

Description

In the old days, you could enter key commands while an ADMB program was running: q to finish the run; n to go to the next phase; and c to invoke the numeric derivative checker. This worked for me when I was running ADMB7 compiled with an ancient Microsoft C++ compiler and running in Win XP (don't laugh). Now in ADMB10 with MS Visual Studio 8 and Win7, these keystrokes are not enabled. All I can do is ^c to abort. I don't know if the issue is with ADMB, the compiler, or Win7. Can you replicate the issue and see if it is an ADMB change.

Rick

History

#1 Updated by Johnoel Ancheta about 2 years ago

  • Status changed from New to In Progress

Duplicated problem. Hitting Ctrl-C aborts the program. This happens just for Microsoft C++ compiler.

#2 Updated by Johnoel Ancheta about 2 years ago

  • Status changed from In Progress to Resolved

Fixed in revision 244. Ctrl-C then derivative checker.

#3 Updated by Johnoel Ancheta about 2 years ago

  • Status changed from Resolved to In Progress

Need to look into the next phase...

#4 Updated by Johnoel Ancheta about 2 years ago

  • Status changed from In Progress to Feedback

Delay task. Need feedback from dave.

#5 Updated by Johnoel Ancheta about 2 years ago

Older versions of ADMB on windows did NOT require ctrl-c to use next phase 'n', final phase 'q' or derivative checker 'c' key presses.

#6 Updated by Johnoel Ancheta about 2 years ago

  • Status changed from Feedback to Resolved

Resolved in revision 248.

#7 Updated by Johnoel Ancheta about 2 years ago

  • Status changed from Resolved to Closed

Feedback good. Keystrokes worked as before...

#8 Updated by Johnoel Ancheta almost 2 years ago

  • Target version set to ADMB 11

Also available in: Atom PDF