Bug #7

Mac issue: "duplicate symbol lgam" still not solved (at least for ADMB download)

Added by Ian Taylor over 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:01/12/2012
Priority:NormalDue date:
Assignee:-% Done:


Target version:ADMB 11


Installed ADMB 10.1 for Mac from downloads page and got this error on compile:

ld: duplicate symbol lgam(double)
in /usr/local/admb/lib/libads.a(cgamdev.obj)
and /usr/local/admb/lib/libdf1b2s.a(df13tester.obj)

Turns out to have been discussed at length since 2010:


#1 Updated by Johnoel Ancheta over 4 years ago

  • Status changed from New to Resolved

The linker error("ld: duplicate symbol lgam(double)") only occurs with 10.1 release. It has been fixed in the trunk (revision 169). To fix the
linker error, remove the file with the duplicate symbol.

$ ar -d $ADMB_HOME/lib/libdf1b2o.a df13tester.obj

#2 Updated by Johnoel Ancheta about 4 years ago

  • Status changed from Resolved to Closed

#3 Updated by Johnoel Ancheta almost 4 years ago

  • Target version set to ADMB 11

Also available in: Atom PDF